Version 1.7 upgrade does not work!

Home Forums Easy FancyBox Pro Version 1.7 upgrade does not work!

Tagged: 

This topic contains 5 replies, has 4 voices, and was last updated by  Sue Horwarth 6 days, 12 hours ago.

  • Author
    Posts
  • #11976

    Michael Muraz
    Participant

    I just updated my site to Easy FancyBox (which includes Pro) to version 1.7. It broke every instance of JQuery on my site! Downgrading back to 1.5.8 fixed it and it’s now working properly. Please fix this!

  • #11978

    Sue Horwarth
    Participant

    I am having problems as well.
    The slideshows that were working were NOT after the upgrade.
    As per the above post, (Thank you, Michael) I went back to my previous installation 1.5.8.2 and got it working again.

    Dashboard is calling for me to do the update, so please let me know when it is fixed.

  • #11980

    RavanH
    Keymaster

    Hi Michael, Hi Sue, sorry to hear you are having these troubles with the latest version.

    Can you share a link to your site?

    It might well be a theme conflict that did not manifest itself before because of the fact the script files where loaded so late in the previous version. This is done differently in 1.7 (to fix other issues) but appears to be a problem mostly for themes that include their own version of the jQuery library or sites using NextGEN where the option to include FancyBox light box script is not deactivated…

  • #12006

    Pharéo
    Participant

    Hi all, you can also send us your site URL via the contact form with mention of this thread, so we can take a look at each case. Even with the downgraded version running, it might be possible to tell what is going wrong with version 1.7

  • #12012

    RavanH
    Keymaster

    Hi Michael, thanks for sending your site URL. I’ve responded by email but I’ll partly repeat my response here so others may benefit:

    Looking at the site source, I see there is another version of FancyBox included in the theme file /themes/jupiter/assets/js/core-scripts.6.1.2.js which makes the theme incompatible with Easy FancyBox. The fact that older worked while 1.7 doesn’t is due to a difference in when it adds its script files. Version 1.6 does this very late while 1.7 does it at the usual point. Both methods have their up and downsides and you seem to be the victim of the downside as the theme incompatibility is now revealed.

    You have two options:

    1. Stick with version https://downloads.wordpress.org/plugin/easy-fancybox.1.6.2.zip for now and wait for version 1.7.1 as it will include an option to makes script files load as late as they did with previous versions. This is the easiest option but will need your attention to NOT update until the next release and then, when it arrives, enable the new ‘theme compatibility’ (or something similar) option. I can send a beta version of 1.7.1 with the planned compatibility option when it’s ready to anyone who wished to test it.

    2. Or modify either the theme (to remove all fancybox related scripts) or the Easy FancyBox 1.7 plugin so the script files are enqueued at a later point. I can give detailed instructions on how to do this for anyone who wants to try this.

    Just let me know on this thread 🙂

  • #12014

    Sue Horwarth
    Participant

    Hi Everyone,

    Don’t really know what “broke” my slideshow, but I did 2 things –
    1. Changed a media setting
    2.  Replaced the galleries (manually) because I simplified the navigation structure to each of the slideshows (there are 4) and it worked.
    I even felt confident enough to do the upgrade and it stayed working fine!

    Thanks for reaching out,
    Sue

You must be logged in to reply to this topic.

Site by Pharéo | Hosted on The Permanently Moving Network