How can I disable de plugin in certain links

Home Forums Easy FancyBox Pro How can I disable de plugin in certain links

This topic contains 3 replies, has 3 voices, and was last updated by  RavanH 2 months, 2 weeks ago.

  • Author
    Posts
  • #12551

    Marcela Benavides
    Participant

    Hi,

    I’m using the autodetect option for my links because I couldn’t ad the class, but I need to disable the plugin un my vimeo social media icon in top menu and in footer, because it opens like lightbox.

    Can you help me to do that?

    HOME

     

  • #12554

    Pharéo
    Participant

    Hi, you can disable the light box effect for menu links like this:
    1. Go to Appearance > Menus and select the top menu
    2. Click on the Screen Options tab at the top right of the page
    3. Place a check mark at CSS Classes under “Show advanced menu properties”
    4. Scroll down to the Vimeo menu item at the bottom of the menu list
    5. Open the menu item for editing and notice the CSS Classes field
    6. Fill in nolightbox there and save the menu.

    For the social links lower on the same page, it might be more difficult. Is that a page builder module? Does it have an option to add custom class names? If so, try adding nolightbox there…

  • #12567

    Marcela Benavides
    Participant

    Thanks, it worked perfectly for the top menu,

    But not for the lower, yes this is a page builder module and I can add costum class names put It didn’t worked. I’m using divi theme.

  • #12569

    RavanH
    Keymaster

    Hi Marcela, the upcoming point release will include a fix to prevent Vimeo user pages from being included by autodetection.

    If you wish, you can apply the fix yourself to your current installation:

    1. Go to your WordPress admin Plugins > Editor page.
    2. Select plugin to edit “Easy FancyBox” and click Select.
    3. In the Plugin Files section on the right, open the /inc folder and choose easyfancybox-options.php for editing.
    4. Scroll down to line 1281 where you should see this:
      
      'selector' => 'a[href*="vimeo.com/"],area[href*="vimeo.com/"]',
      
    5. Paste :not([href*="/user"]) right after the first ] and the comma behind it, so that the line will look like this:
      
      'selector' => 'a[href*="vimeo.com/"]:not([href*="/user"]),area[href*="vimeo.com/"]',
      
    6. Then hit Update File and visit your front page to test the result.

     

    Hope that helps 🙂

You must be logged in to reply to this topic.

Site by Pharéo | Hosted on The Permanently Moving Network