Disable Fancybox on a Page?

Home Forums Easy FancyBox Pro Disable Fancybox on a Page?

This topic contains 4 replies, has 2 voices, and was last updated by  RavanH 1 year, 4 months ago.

  • Author
    Posts
  • #6878

    Nicole Young
    Participant

    I use a plugin called “Vimeography Pro” which showcases a collection of videos on a page, kind of like a gallery, and Fancybox is opening up all of the videos at different sizes in the pop-up.

    – Changing the dimensions in the settings does not work
    – Using the class=”nofancybox” (or class=”nolightbox”) does not work

    Is there a way to disable Fancybox for an entire page?


  • #6882

    RavanH
    Keymaster

    Hi Nicole, welcome on these forums!

    The fact that class=”nofancybox” does not work surprises me. In normal circumstances, it should prevent vimeo links from being auto-detected by FancyBox. I wonder why that does not seem to be the case on your site. Can you share a link so I can take a look and see it live?

    You can send the link via the form on the Contact page if you wish to keep the (development) site address private.

    But to answer your question: yes it is possible to completely disable fancybox on a particular page but i’m afraid it’s not as simple as checking a box somewhere. I can give you a step-by-step description of a possible approach if you like…

    • #6884

      Nicole Young
      Participant

      Thanks! I sent a message using the contact form.

  • #6892

    RavanH
    Keymaster

    Thanks Nicole, I got the link.

    Looking at the page source, I see other FancyBox script that is not coming from Easy FancyBox. In fact, alongside FancyBox, another version of the light box is loaded. It’s probably theme that includes FancyBox… Is there an option in the theme to disable the light box effect?

    If not, the only option is either to remove everything FancyBox related from the theme manually or disable Easy FancyBox. Running two versions of a script at the same time is certainly going to create weird issues, as we can see here.

  • #6893

    RavanH
    Keymaster

    Looking more closely, I notice you have not enabled the Vimeo option on Settings > Media at all. Easy FancyBox is not even involved here. It’s all coming from that other version.

    I suspect it’s the Vimeography plugin that is including this other FancyBox version… You’ll need to find a way to disable the light box effect in the Vimeography settings, or (if there is no such option) ask their support: either how to make all videos the same size or how to disable the plugin’s built-in light box effect.

You must be logged in to reply to this topic.

Site by Pharéo | Hosted on The Permanently Moving Network