Adding thick border to overlay picture

Home Forums Easy FancyBox Pro Adding thick border to overlay picture

Tagged: 

This topic contains 7 replies, has 2 voices, and was last updated by  Pharéo 3 months, 3 weeks ago.

  • Author
    Posts
  • #7613

    Leslie Ann Levine
    Participant

    Hi. Can you help me add a thick (60+ pixel wide) border to the pictures when they display on the overlay? My client really wants this thick border and I had thought just changing the border size in the plugin would work, but it doesn’t seem to be doing anything — or maybe I’m not understanding what that border feature is for. I’m using the nextgen plus thumbnail gallery plugin.

    Thanks!

  • #7614

    Pharéo
    Participant

    Hi Leslie Ann, welcome on these forums.

    Setting the border should indeed “just work” but when using NextGEN there might be conflicting files being loaded.

    First, make sure all lightbox effects in NextGEN are disabled: navigate to Gallery >> Other Options and select Lightbox Effects. There select from the drop down “No lightbox”. Then test the front end again.

    If the border remains small, I can take a quick look to see if there is still some conflict going on. Can you share a link to your clients (development) site? If you prefer to keep it private, please use the contact form mentioning this thread.

    Otherwise, you may need to search for conflicting files in the site’s source code yourself. See if there are files like fancybox.xxx.js or fancybox.xxx.css being added from other directories than the /wp-content/plugins/easy-fancybox/ directory. But it might be more difficult than that. Some themes include conflicting script and styles in custom files…

  • #7615

    Leslie Ann Levine
    Participant

    I turned off the lightbox effects in nextgen and now there’s no slideshow at all just a single picture in a new window.

    My test page link is Any help would be most welcome.

  • #7618

    Pharéo
    Participant

    Hi Leslie Ann, you could set the Auto-gallery option on Settings >> Media to “All in one gallery” but this might not suit your needs as it will automatically include every (linked) image on the same page, not only the images in one NextGEN gallery.

    The option “Galleries per Section” could be used to limit the images to each NextGEN gallery but we’ll need to find which class (if any!) is used by NextGEN to wrap its gallery code. I can take a look for you but it seems the link got swallowed by the forum system somehow. Could you post it again?

  • #7623

    Leslie Ann Levine
    Participant

    The link is http://wp.me/P7nrjX-3tK

    I had hoped that by using the custom feature in the lightbox options I could get nextgen to use the easy fancybox scripts, but that obviously doesn’t work. I’d really appreciate any other suggestions you might have to make this work.

  • #7627

    Pharéo
    Participant

    OK I see there is a rather serious blocking error occurring :

    
    Uncaught Error: Syntax error, unrecognized expression: [href=#]
    

    This is caused by an incompatibility of the theme’s script file wp-content/themes/Avada/assets/js/main.min.js with jQuery 1.12… You need to update the theme, or ask the theme devs to fix it. Or fix it yourself by editing main.min.js (in a flat text editor!) and replace all occurrences of href=# with href='#'

    After that, Easy FancyBox should start working and you can disable the one included with NextGEN.

  • #7629

    Leslie Ann Levine
    Participant

    You are amazing. Thanks so much for the help.

  • #7632

    Pharéo
    Participant

    Glad I could help 🙂

    Attention: there is still one [href=#] in there. The error still occurs as long as that’s not [href='#']

    Tip: You can see errors like this when opening the browser Developer Tools in the Console tab.

You must be logged in to reply to this topic.